3DSlicer (binary version) crashes with extension manager

Hey guys,

I am struggling a lot with extension manager of Binary 3DSlicer version and all my developer version ones: Every time I open extension manager it either collapse right away or loads but freezes somewhere.

I use Linux Mint 18.3 Cinnamon 64 bit.

I’ve tried with three or two latest versions of 3DSlicer, both developer and binary versions.

Thanks in advance!

Does it help if you remove all files and folders from your application settings folder (where Slicer.ini is located)?

Does it crash if you are disconnected from the internet?

Can you get a stack trace of the crash?

I’ll check the points you suggested.
I just tried in another Linux mint machine and it happened again.

Then, I tried in my Windows 10 (updated) installation and everything worked fine, nice and smooth.

Please also check this thread and try the suggested solutions (force using OpenGL compatibility profile, update your display driver): Opening extension manager makes Slicer crash on Linux

1 Like