Elastix registration returns with failure

Hi Andras,

This looks promising!

I just tried a general registration and got this:
CalledProcessError: Command 'elastix' returned non-zero exit status 1

Also, I have a question: does one have to Create new ScriptedModule in the Parameter set button?

@ihnorton I tried uploading the error log but got this message:
Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif).

Best,
Fernando

You can copy paste the relevant part of the log and a link to the full text of the log (on dropbox, onedrive, …)

Good point, the widget is there, but it is not used for anything now. I’ll add saving of node selections into the parameter node (https://github.com/lassoan/SlicerElastix/issues/1).

I was trying to upload the .log file. [Trying from GMail now]

I see that it didn’t work. I’ll just send you the file by email.

I confess I have never been sure what a parameter node is. I tried the link in the wiki, but it’s dead.

I’ve updated the link, the slides are available here:

Parameter node stores your node and parameter selection so that if you save the scene and reload it you can just click on Apply to run the processing again.

Parameter nodes allow you to set up complete processing pipelines using CLI modules (select the output of a CLI as in input of another CLI). You just load the scene, select data set as input, and the pipeline is re-executed automatically and you see the output as soon as the processing is completed. It only works for CLI modules though (and for loadable and scripted modules that has auto-run/auto-update feature implemented).

1 Like

@Fernando used a yesterday’s Slicer version that had still some issues. There should be no problem in the latest nightly version.

Working fine now.

Is there a way to choose the type of registration (rigid/affine, etc.) instead of having to choose a preset?

Type of registration (and many other parameters) are defined by the preset. It could be possible to add some level of preset editing/saving inside the module, but now it’s manual (editing text files; the presets folder can be opened from the Advanced section).

1 Like

A post was split to a new topic: Elastix registration fails