SlicerRT DRR generation module does not work well on macbook

Operating system:mac os 13.0
Slicer version:5.0.3
Expected behavior: I want to use the “DRR generation” module in plastimatch. However, the generation results are always black. All of the setting parameters are default. And this module can be used normally in my Windows system. How can I normally use it in the macOS system?
Actual behavior:

Are you observing the same error on macOS as you mentioned on your previous thread:

:sob:Would you mind please telling me which file I should change the permission?
I have tried change the read and write permissions of the files circled in red in the picture below. However, the problem still exist.

Can you show the settings that you have selected in “Process Parameters” dropdown? I encountered a similar problem when I had “pgm” or “pfm” selected instead of “raw.” Should already be “raw” if you set all parameters to their default values, but I thought it’d be worth mentioning.

Thanks for your remind. I have checked the “Process Parameters” and it’s “raw” :sob:

Have you installed Slicer? Is your temporary directory writable?

Yes, I have installed Slicer. I check the temporary directory and it’s writable.

Could somebody check if this behavior is reproducible on any macOS device? Just install SlicerRT, go to “DRR generation” module, select an input and output volume, and click Apply.

Looks fine to me. Tested on a mac pro.

@suzume check your Temporary directory to confirm it is read/write for you.

Here’s the log:

Found CommandLine Module, target is  /Applications/
ModuleType: CommandLineModule
DRR generation command line: 

/Applications/ --sad 1000 --sid 1300 --vup -1,1.22465e-16,1.22465e-16 --normal -1.22465e-16,-1,2.22045e-16 --isocenter -1.7,21.1,12.2 --dim 2000,2000 --spacing 0.25,0.25 --subwindow 0,0,1999,1999 --autoscale --autoscaleRange 0,255 --exponential --thresholdBelow -1000 --threading cpu --huconversion preprocess --algorithm uniform --outputFormat raw --negative /private/var/folders/cn/kmqx4dm17gx4hrllqrmnkbp00000gn/T/Slicer-pieper/HJCJI_vtkMRMLScalarVolumeNodeB.nrrd /private/var/folders/cn/kmqx4dm17gx4hrllqrmnkbp00000gn/T/Slicer-pieper/HJCJI_vtkMRMLScalarVolumeNodeD.nrrd 

DRR generation standard output:

Src range = 0.590037 1.000000
Dst range = 0.000000 255.000000
Slope = 622.008057, Offset = -0.590037
I/O time: 0.040724 sec
Total time: 65.379 secs

DRR generation completed without errors

Loaded volume from file: /private/var/folders/cn/kmqx4dm17gx4hrllqrmnkbp00000gn/T/Slicer-pieper/HJCJI_vtkMRMLScalarVolumeNodeD.nrrd. Dimensions: 2000x2000x1. Number of components: 1. Pixel type: float.