VMTK vessel filtering not working

Operating system: macOS
Slicer version: 4.5
Expected behavior:
Actual behavior:

Hello again,

Trying to use the VMTK module which I recently downloaded. When I select the vessel filtering option I get a “failure to load VMTK libraries” error message. The other options seem to work fine.

Any ideas?


Version 4.5 is very old. Please try with the latest release 4.8.

Thanks for the reply Steve.

I’ve tried with 4.8 and the latest 4.9 version - same behavior.

When I use the Segmentation module, the options load but the ‘Start’ button
is disabled. I add all the details I can as well as seeding the vascular
tree on the image but it remains greyed out…

Does the Mac version generally have more problems than the windows version?

Could you please copy here a screenshot (make sure no patient name and ID is displayed in slice views) and check if there are any error messages printed in the Python console (Ctrl+3)?

I just tried the vmtk extension on mac with Slicer 4.8 and confirmed it isn’t working.

There’s an issue with the python library:

>>> import vtkvmtkSegmentationPython as vtkvmtkSegmentation
Traceback (most recent call last):
  File "<console>", line 1, in <module>
ImportError: dlopen(/Applications/Slicer-4.8.0.app/Contents/Extensions-26489/SlicerVMTK/lib/Slicer-4.8/qt-loadable-modules/Python/vtkvmtkSegmentationPython.so, 2): Library not loaded: libvtkvmtkSegmentationPythonD.dylib
  Referenced from: /Applications/Slicer-4.8.0.app/Contents/Extensions-26489/SlicerVMTK/lib/Slicer-4.8/qt-loadable-modules/Python/vtkvmtkSegmentationPython.so
  Reason: image not found

@jcfr Could you have a look? I think this worked before (but maybe just on Windows and Linux).

Hi Andras,

Images below: before scrolling down the module window:

After scrolling down to the start button

@pieper confirmed this is a building/packaging error on MacOS. We are working on releasing a new stable version, so most likely we cannot fix this issue in the next 2 weeks. You can track its status by watching this issue: https://github.com/vmtk/SlicerExtension-VMTK/issues/11

Until the problem is fixed, you can run a Windows version of Slicer (using Parallels) or try to use VMTK directly, using command-line tools (see http://www.vmtk.org/).

Thanks for the update Andras. I’ll try the windows or linux version

This is still not working, I just had the same issue.

Latest nightly works for me on both Windows and Linux. Haven’t tested Mac.

Seems to be ok with latest build on Mac too.

1 Like

@Fernando - VMTK doesn’t appear in the Extension Manager in Slicer 4.9 Nightly 4/Dec/17 on MacOS X 10.13.

Am I missing something obvious?

@MBJS I’m not sure what you mean. I can see VMTK on the Extensions Manager (on macOS 10.12.6).

That’s interesting.
When I search in Slicer 4.8.0, VMTK is in the Extension Manager.
When I search in Slicer 4.9 Nightly, it does not appear there.

Sometimes nightly build fails for certain extensions, so the nightlies are not always perfect. Unfortunately in this case it seems that VMTK build fails consistently:
This was the last successful build, on November 19:

The logs show a linking error when trying to find vtkCommonExecutionModelPython.

Awesome! Thanks for hunting the down @cpinter! Much appreciated

The culprit is this commit in VMTK: https://github.com/vmtk/vmtk/commit/58c882900cacb66a1f6e5bd26f248b937a362ee8

I update the git hash in VMTK extension to use the last working version until we fix the VMTK master. So, VMTK should be available in the nightly build again from tomorrow.

1 Like

Thanks @lassoan ! I’ll wait for the next mac nightly build.
Just downloaded the 4/12/17 Nightly, and its still to show up.

Probably you’ve tried it too early in the morning (US time). It should be available now on Windows and Linux.