3D Slicer crashed when clicking on the Segment Editor button


I am working on a segmentation task and I am given an example as a RTSTRUCT.dcm file. After loading it into 3D Slicer, I can visualize the corresponding 3D model and the segmentation (with different colors). However, when clicking on the Segment Editor button (I want to see the labels), the app closed. I guess this is a bug? Or maybe I did something wrong.

I am using 3D Slicer 4.10.0 on macOS 10.14.2.

Thank you in advance for your help!

Do you have this problem with the latest nightly version of Slicer?

If yes, then most likely you have run out of memory. How much physical memory do you have in your computer? How much free disk space?

Freeing up 50GB disk space may solve the problem.

Thanks, @lassoan !
Sorry for my late reply, as I missed the notification email.
I have 8GB of RAM, and 30GB of disk space left. Is that a bug that Slicer requires 50GB of free space for that feature? It is quite a lot :o
I am going to try the nightly version and get back. Thanks!

@lassoan Unfortunately the SlicerRT extension, which I need, does not support the nightly build yet :frowning:

Depending on how many structures you have and the resolution of the volume, you may need a lot of memory space. 30GB disk space should be enough if the data set is not extremely large or fine-resolution.

Could you try with latest stable version (4.10.1)?
Can you share an anonymized data set that reproduces the problem? (or if you can save the segmentation and you can reproduce the issue by reloading that saved segmentation then that will work, too)

@lassoan Thanks.
4.10.1 also crashed. I am going to try it on a Linux machine to see, and try saving/reloading as you suggested as well.
Regarding the data I’m not sure that I can share them, maybe but I’ll have to ask.
Thanks again!

I am really sorry for my delayed feedback. I have tried on two different Linux machines (Ubuntu and Linux Mint) and the problem still occurs. I also tried saving the segmentation and reloading it but the software still crashed when I click on the Segment Editor button. I’ll send you the data by private message later today when I get home, so that you can reproduce the issue. Thanks again!