3d Slicer - MonaiLabel - custom labels


Windows 10, Slicer 3D 5.6.2, MonaiLabel 0.8.1.
I have a functioning Nvidia card with cuda support.
I ran the ‘hello world’ spleen segmentation.

I converted my dicom files to nifti, it works until I use custom labels in the monailabel config. If I use only 1 of my custom labels everything seems fine. After adding at least 1 more custom label, things are getting messy.
I’m unsure what I’m doing wrong.

Somewhere I read try to change the application (radiology) name. May it be the solution?

(I tried to use the --conf use_pretrained_model false, or changing it in the conf, the error is consistent)

Traceback (most recent call last):
File “G:/prog_app/Slicer 5.6.2/slicer.org/Extensions-32448/MONAILabel/lib/Slicer-5.6/qt-scripted-modules/MONAILabel.py”, line 1545, in onClickSegmentation
result_file, params = self.logic.infer(model, image_file, params, session_id=self.getSessionId())
File “G:/prog_app/Slicer 5.6.2/slicer.org/Extensions-32448/MONAILabel/lib/Slicer-5.6/qt-scripted-modules/MONAILabel.py”, line 2321, in infer
result_file, params = client.infer(model, image_in, params, label_in, file, session_id)
File “G:\prog_app\Slicer 5.6.2\slicer.org\Extensions-32448\MONAILabel\lib\Slicer-5.6\qt-scripted-modules\MONAILabelLib\client.py”, line 344, in infer
raise MONAILabelClientException(
MONAILabelLib.client.MONAILabelClientException: (1, ‘Status: 500; Response: Internal Server Error’)

The name change did not solve the problem. I’ve tried to manipulate the pip installs but had no success.

The error was on my side.
I found in another forum:
" remove all files in the model folder"

this solved the problem. It has to be done if the training is from absolute zero (“scratch”)

1 Like