4.9.0 nightly build cannot be run on a VNC server due to Qt5-GLX problem

I am using a VNCviewer to connect to a remote Ubuntu 16 server, where I have installed 3DSlicer.

I downloaded the stable release and run it without problems as:

user@pgdev:~$ /opt/Slicer-4.8.1-linux-amd64/Slicer
Number of registered modules: 161
Number of instantiated modules: 161
Number of loaded modules: 161
Switch to module: “Welcome”
Loaded volume from file: /home/user/.config/NA-MIC/Extensions-26813/SlicerVMTK/lib/Slicer-4.8/qt-scripted-modules/Resources/Vesselness.png. Dimensions: 65x50x1. Number of components: 3. Pixel type: unsigned char.

However, with the nightly build 4.9.0, it does not work any more, thus I report the problem.

user@pgdev:~$ /opt/Slicer-4.9.0-2018-06-11-linux-amd64/Slicer
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-user’
QXcbConnection: Failed to initialize XRandr
Qt: XKEYBOARD extension not present on the X server.
Could not initialize GLX
error: [/opt/Slicer-4.9.0-2018-06-11-linux-amd64/bin/SlicerApp-real] exit abnormally - Report the problem.

Seems to be a Qt5 issue. I tried the solutions posted here, but to no avail: https://github.com/spyder-ide/spyder/issues/3713

Here my system info:

user@pgdev:~ uname -a Linux pgdev 4.4.0-127-generic #153-Ubuntu SMP Sat May 19 10:58:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux user@pgdev:~ cat /etc/os-release
NAME=“Ubuntu”
VERSION=“16.04.4 LTS (Xenial Xerus)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 16.04.4 LTS”
VERSION_ID=“16.04”
HOME_URL=“http://www.ubuntu.com/
SUPPORT_URL=“http://help.ubuntu.com/
BUG_REPORT_URL=“http://bugs.launchpad.net/ubuntu/
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

You could try export LIBGL_ALWAYS_INDIRECT=1, in the shell, before launching Slicer.

Thanks, but does not work, I get the exact same error message.

As an alternative solution, you can use virtualgl on your vncserver. You will need to execute the slicer through vglrun command.

https://virtualgl.org/vgldoc/2_1_1/

1 Like

@ferhue another user reported this problem. Can you let us know what worked for you? Were you able to figure this out?

I never solved it, I just used it with grdesktop instead of VNC viewer.

I just tried again with Ubuntu 18 and Slicer 4.10.1 and it does not crash, however I get a black screen.

Below the errors printed in terminal:

1 Like