Add Data dialog box appears black the second time it's opened

Hi, I’ve noticed that in versions starting from 5.0 in Linux (Ubuntu 22.04) the Add Data dialog box appears completely black the second time it is opened. I’ve tested it in 5.0, 5.2.1, 5.2.2 and 5.3 (preview). The first time it’s opened it works fine, but after closing and re-opening it doesn’t show anymore. If being opened by dragging and dropping a file, even though it is black the file will be opened after pressing enter, so the functionality is still there but just isn’t displaying correctly. In version 4.8 it works fine.

Thanks for your help.

Hmm, that’s odd. I mostly use Ubuntu 20.04 and have never seen that. Perhaps it’s a driver issue or something.

Maybe someone else can comment if they have seen similar issues?

Thanks for you reply. I updated the NVIDIA drivers to the latest version (525) on my computer (GeForce GTX 1070) and still have the issue. I also tried it on three other computers (2 desktops with HD Graphics 630 and a laptop with Iris XE) with freshly installed Ubuntu 22.04 (I had to install libxcb-xinerama0) and also found the same issue.

If there’s anything that I could try let me know. Thanks

That’s strange. I can have a look in my systems and get back to you (and eventually open an issue if I can reproduce this behavior).

Thanks, I’ve found that the Python console shows this error four times when it fails to show the dialog box:

[Qt] QXcbConnection: XCB error: 8 (BadMatch), sequence: 7165, resource id: 94371965, major code: 130 (Unknown), minor code: 3

I can’t reproduce this error on my Ubuntu 22.04 (nvidia drivers). I have tried both latest stable and preview (are you running on Wayland?). I would think the best candidate for this problem is a dependent package missing :

  1. Make sure you have all the dependencies required for Slicer installed (Getting Started — 3D Slicer documentation)

  2. If this does not work, I would suggest that you install the packages we normally use for development (this may pull whatever dependency is missing (GNU/Linux systems — 3D Slicer documentation), this is a difference between my Ubuntu 22.04 and a fresh install:

sudo apt update && sudo apt install git subversion build-essential cmake cmake-curses-gui cmake-qt-gui \
  qtmultimedia5-dev qttools5-dev libqt5xmlpatterns5-dev libqt5svg5-dev qtwebengine5-dev qtscript5-dev \
  qtbase5-private-dev libqt5x11extras5-dev libxt-dev libssl-dev
  1. If none of these works. You can scan through (Can't start latest stable on ubuntu 20.04 - #18 by manjula), which was a long discussion around xcb-related problems. Perhaps some of the answer could be useful.

  2. If none of this works, I could try to reproduce this in a fresh installation.

Let us know how this goes.

Thanks for the suggestions. All computers were on X11 but one. I’ve now realized that the issue appears only if the Add Data dialog box is closed using the “x” from the window. If I load some data or if I close it using “Cancel” it works fine. I have all dependencies and installing the development packages didn’t fix it. I’ll have look at the link you provided.

Thanks again.

You might also try building from source to see if this is an issue with the packages or something at the Qt or window manager level. You could also try different window manager environments to see if that makes a difference.