Alpaca error in 'Run Subsampling'

Operating system: Windows 11
Slicer version: 4.13.0-2022-03-10
Expected behavior: Run subsampling
Actual behavior: Error in running subsampling

Hi all,

I’m new to SlicerMorph. I downloaded it a few days ago, but unfortunately the Sandbox extension wasn’t available. SO I ended up downloading the SlicerMorph Nightly version. That worked and I was able to get all the extensions I needed.
Going through the tutorial for running Alpaca (here), I ran into an error when I click ‘Run Subsampling’:

:: Loading point clouds and downsampling
Traceback (most recent call last):
File “C:/ProgramData/NA-MIC/Slicer 4.13.0-2022-03-10/NA-MIC/Extensions-30699/SlicerMorph/lib/Slicer-4.13/qt-scripted-modules/”, line 352, in onSubsampleButton
self.targetFeatures, self.voxelSize, self.scaling = logic.runSubsample(self.sourceModelSelector.currentPath,
File “C:/ProgramData/NA-MIC/Slicer 4.13.0-2022-03-10/NA-MIC/Extensions-30699/SlicerMorph/lib/Slicer-4.13/qt-scripted-modules/”, line 903, in runSubsample
source_down, source_fpfh = self.preprocess_point_cloud(source, voxel_size, parameters[“normalSearchRadius”], parameters[“FPFHSearchRadius”])
File “C:/ProgramData/NA-MIC/Slicer 4.13.0-2022-03-10/NA-MIC/Extensions-30699/SlicerMorph/lib/Slicer-4.13/qt-scripted-modules/”, line 944, in preprocess_point_cloud
from open3d import registration
ImportError: cannot import name ‘registration’ from ‘open3d’ (C:\ProgramData\NA-MIC\Slicer 4.13.0-2022-03-10\lib\Python\Lib\site-packages\

Open3d didn’t have any issues installing when I had first opened Alpaca. I opened the python interactor window, typed
import open3d

and the version I have installed is 0.15.1

Alpaca didn’t automatically install pycpd, so I went ahead and installed it : pip_install(“pycpd”)
But I keep getting the ImportError everytime I try and click run subsampling. I’ve tried uninstalling open3d, then reinstalling. I’ve also tried installing open3d versions 1.10 (which doesn’t even want to install) and version 1.14.1, but the error persists.

I also don’t have some features within the Single Alignment tab that the tutorial has, such as the ‘Select subsampling voxel size’. I don’t know if that’s going to harm me down the road.

Any suggestions on how I can get past the ‘Run Subsampling’ without encountering this error?

@Christianne thanks for reporting this. The fix for this issue in the Preview version will be available later today on our repository, or in the extension manager tomorrow.