ALPACA module doesn't correctly register models of different size

I’ve segmented out the premaxilla of several guppies that I CT scanned. I place landmarks on one of the models and am trying to use ALPACA to transfer these landmarks to other models. This works well when I use two models that are very similar, but does not work to transfer landmarks between males and females (females are about twice as big as males).
I have tried changing the alpha and beta values but this doesn’t fix the problem.

I’m wondering if ALPACA is able to deal with similar structures that are different sizes? Does either registration step account for size or do they only account for position and local shape change?

Thanks for any help!

@Dave_Matthews @smrolfe and @agporto are working on that. It should be fixed in the next couple days…

We’re just testing now, and will be updated shortly!

Thanks very much for the quick reply!

Hi Smrolfe,

Recently I also meet the similar problem, do you have an answer now?

Best regards,

Hi Muratmaga,

Do you have any suggestion now? Or is there any similar post about transfer landamrks in Slicer?

Best regards,

That has been fixed sometime ago, and there is now a scaling option built-in (you can disable it by choosing skip scaling).

If it is still not working right for you, please share the two models and the LMs you want to transfer.