Bad_alloc error in import open3d

Yes, should be able to specify the whl directly.

This worked for me to install this package


@muratmaga How did the manual whl building go to resolve your issue here?

I think it could have worked, if I managed to build open3d 0.10. I can build 0.13 (which doesn’t help us), and install, but unfortunately 0.10 doesn’t seem to work with provided instructions (some external library install is failing).

Can you remind me why you’re unable to update to using the latest version of Open3D?

As a package that includes a large amount of external dependencies, even though you may be specifying a specific version it may not always have the same dependencies.

Because almost at every version, they change their API in ways that breaks our functionality. We don’t have the bandwidth to keep updating every 3-4 months. So we are looking in find a way to wean ourselves. Feel free to make comments/suggestion on this thread.

When trying to import individual components, I get a more informative error:

from open3d.cpu.pybind import (camera, geometry, io, pipelines, utility, t)

ImportError: generic_type: cannot initialize type “VerbosityLevel”: an object with that name is already defined

I am wondering if that is somehow related to the Qt5 update since it also has a ‘VerbosityLevel’ definition