BoneTexture extension Attribute error

I encountered an error with BoneTexture module, it’s probably because it wasn’t updated with the latest code changes from 3D Slicer.

As soon as I load the BoneTexture module, an error was thrown in the console and none of the function would work.

Traceback (most recent call last):

File "/Applications/", line 155, in setup

self.vectorToScalarVolumeConversionWidget = VectorToScalarVolume.VectorToScalarVolumeConversionMethodWidget()

AttributeError: module 'VectorToScalarVolume' has no attribute 'VectorToScalarVolumeConversionMethodWidget'

I’ve looked around the commit history of Slicer and VectorToScalarVolumeConversionMethodWidget was removed in this commit in 2022

I’ve tested this on Windows, MacOS (M2) and Linux, it’s throwing the same error.
I’ve tested this multiple stable releases from latest preview (5.5.0-2023-11-14) to 5.0.2.
The last working 3D Slicer version for this extension is 5.0.3.

You can report this at the BoneTexture repository:

Even better, maybe you an propose a fix.

Thank you for your reply. I’ve tried to take a look at the code but due to my unfamiliarity with Slicer’s internals, I have no ideas how to fix it or where to even start. I will create an issue in the extension’s issues tracker