Bug during 3DSlicer installation

Hi, guys.

I’m trying to install Slicer release 4.10.2 in my Linux Mint 18.3 Sylvia Desktop.
I correctly installed CMake 3.13.4 and Qt 5.11.0.
I go with CMake, configure and generate, everything goes ok!

But when I do sudo make in the slicer build folder… it runs and crashes with the following error:

CMake Error at PCRE-prefix/src/PCRE-stamp/download-PCRE.cmake:159 (message):
Each download failed!
error: downloading 
'https://github.com/Slicer/SlicerBinaryDependencies/releases/download/PCRE/pcre-8.38.tar.gz' failed
     status_code: 1
     status_string: "Unsupported protocol"
     --- LOG BEGIN ---
     Protocol "https" not supported or disabled in libcurl

Closing connection -1

As trials to fix it, I did reinstall to the latest version OpenSSL and Clurl --with-ssl, with the last one not working well (I then installed that through synaptic). But no success at all.

Any help is very welcome.

P.S. I just installed pure ITK 5.0, everything worked very well!

This error seems to be a CMake SSL configuration error, which is not related to Slicer. There are several similar error reports on the web (such as this) - one of the suggested solutions should work for you, too.

1 Like

Thanks, Andrass.

Checking that right now!

Just curious, why do you use sudo for building Slicer?

I guess I do this just to be sure it will not stop with some “permission denied” error… haha


In fact, as Andrass pointed out, it was a CMAKE PROBLEM. I did as it follows:

install the lib libcurl4-openssl-dev::

sudo apt-get install libcurl4-openssl-dev

Rebuild CMake from source with the following comands:

sudo ./bootstrap --system-curl
Make install

Finally, I ran the standard recommendations for building 3D SLICER!

1 Like

Thanks for the update.

To simplify your workflow. Instead of building CMake from source, I suggest you download the CMake binaries available at https://cmake.org/download/

1 Like