Build error on linux

Hi, I have a build failure on linux (debian stable, gcc 6.3.0).
Fresh build directory, DCMTK fails. Excerpts below. Any idea?

[ 48%] Performing configure step for ‘DCMTK’

– Info: C++11 features disabled

[ 0%] Building CXX object
In file included from /usr/include/c++/6/cstdint:35:0,
from /home/gcs6/build/slicer-4/Slicer-
from /home/gcs6/build/slicer-4/Slicer-
from /home/gcs6/build/slicer-4/Slicer-
from /home/gcs6/build/slicer-4/Slicer-
from /home/gcs6/build/slicer-4/Slicer-
/usr/include/c++/6/bits/c++0x_warning.h:32:2: error: #error This file
requires compiler and library support for the ISO C++ 2011 standard.
This support must be enabled with the -std=c++11 or -std=gnu++11
compiler options.

The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the e-mail
contains patient information, please contact the Partners Compliance HelpLine at . If the e-mail was sent to you in error
but does not contain patient information, please contact the sender and properly
dispose of the e-mail.

How do you configure Slicer ?

After reading CMakeLists.txt, I learned that I could tell Slicer to use
c++11 by changing the VTK version.

I would propose changing that logic to the below, so that one could
choose on the command line to enable c++11 even with VTK 7.

If you like I can give a pull request.

Since we will soon transition to C++11, Qt5 and VTK8 as the default. I am sure it is worth the effort.

If c++ 11 is required, I suggest you configure Slicer (from a clean build tree) with

cmake  -DQt5_DIR:PATH=/path/to/lib/cmake/Qt5 ../Slicer

The performance gain I have seen with Volume Rendering using VTK8 is a game changer. I don’t think it’s worthwhile to spend resources with VTK7.