Can't start latest stable on ubuntu 20.04

@pieper qt5dxcb-plugin seems to be a component of QtGui that can be built with the -qt-xcb flag (Qt XCB). I guess to include this in the slicer packaging QT should be included as a whole? I’m with you on avoiding the user installing packages to use the packaged binaries, but we need to be careful not ending up packaging all the way to the Linux kernel :wink:

3.4~20200819gead65ca871-0ubuntu3

thanks @manjula. It is exactly the same version as in Ubuntu 20.10. We may not be hitting the right diagnostic here with the compatibility. Would you mind to paste a list of your installed packages in dpaste?

to do this you can install xclip:

sudo apt install xclip

and then copy the list of packages in the clipboard

sudo apt list --installed | xclip -selection c

thenk you can go to dpaste, paste (Ctrl+V) the results and post here the link. If PoP is almost Ubuntu, maybe we find the difference.

Thanks in advance.

Please note that most of my packages i have is in flatpak but here is the link.

I mentioned about flatpak because when I was figuring out what was going wrong with linkSlicerBlender the deb version of the Blender was giving error in importing numpy, Apparently it was a know issue with blender but when i switch to flatpak it went away.

I have installed PopOS 20.10 (also the packages from @manjula) and got the same results as with Ubuntu 20.10:

  • Error due to missing libxcb-xinerama0 on Slicer stable (4.11.20200930). When libxcb-xinerama0 is installed, segmentation fault is produced on startup.
  • Segmentation fault is removed by compiling python with BUILTIN_CTYPES=ON.

I still think the problem is leaning towards a compatibility problem between python and libffi 3.4.

2 Likes

I think I am experiencing the same issue with Ubuntu 20.10. Can you tell me how to use the BUILTIN_CTYPES=ON work-around? I have not been able to figure it out from the online documentation. Thanks!

This is a build option for the cpython-cmake-buildsystem project, you can enable this option adding

-DBUILTIN_CTYPES=ON

under CMAKE_CACHE_ARGS in this file:

Then, you would have to re-build Slicer from the top-level.

1 Like

Thanks! Adding -DBUILTIN_CTYPES:BOOL=ON worked. Though the extension I need doesn’t won’t run in the latest build. Oh well, it’s been that kind of year.

Which extension it is ?

Segmentation Wizard. It last worked for me in 4.10.2. The extension seems to install OK and I can see it in the Extensions manager window, but I can not find it under modules in the main program and it is listed as “not loaded” when I search using Module finder. Thanks for any help; I just need to finish up a little bit of old data.

Yes. Your system is not compatible with the precompiled binaries that we provide.

I today tried building Slicer in Manjaro Linux on a fresh install. it failed, with the following errors.

This is the output from the finals parts

As @RafaelPalomar said i checked the version of libffi

core/libffi 3.3-4 [installed]
Portable foreign function interface library
community/haskell-libffi 0.1-20
A binding to libffi
multilib/lib32-libffi 3.3-2 [installed]
A portable, high level programming interface to various calling conventions (32-bit)

@manjula, I think your problem is not related to the issue discussed in this thread. This thread is starting to be a mix of different issues and is becoming difficult to follow. I suggest that you open a new thread for discussing it.

Regards,
Rafael

1 Like

It may be better to keep this thread as general discussion topic here and create separate issues in the issue tracker to discuss technical details there.

apt-get install libxcb-xinerama0-dev

seemed to work for me on ubuntu 16.04

1 Like

I found this solution here and worked fine for me:

sudo apt-get install --reinstall libxcb-xinerama0
1 Like

Thank you. This is also described in the Slicer install instructions.

@Karam_AbuGhalieh Do you have a suggestion how to make the instructions easier to find?

2 Likes

I was there before facing the problem, now I am surprised the solution is there!

I think what I did is just reading the Linux section and ignoring the next Debian/Ubuntu one!!

Note that for another machine where I started from a fresh unbuntu 20.04 that wasn’t configured as a desktop workstation I also needed to add this package to get past the xcb startup issue: sudo apt-get install libxcb-shape0

I also installed these packages to get xvfb-run to work with Slicer:

sudo apt-get install libxcb-icccm4-dev libxcb-image0-dev libxcb-keysyms1-dev libxcb-randr0 libxcb-render-util0 libxcb-xkb-dev libxkbcommon-x11-dev