Could not find QtWebEngineProcess

I would like to build Slicer with Qt5 and VTK9 and 10 minutes ago the compile process was completed but I can’t run Extension Manager because of error: Could not find QtWebEngineProcess.
But that file exist in:
/home/software/medical/slicer4.9/Slicer-Build-Support/qt/5.11.0/gcc_64/libexec/QtWebEngineProcess

I only do this to check if the SlicerJupyter module works. Doens’t work in my current build (4.9 from May, Qt4, VTK 7) after installation can’t find JupyterKernel module. This is very important to me, because at my institute we conduct research that perfectly fits into Slicer. And I need compiled version, because I write modules and slicelets.

Regards

If you build Slicer then you have to build all the extensions that you need, too, so for now you can ignore the extension manager error.

SlicerJupyter extension nightly build fails with some uuid library issue (http://slicer.cdash.org/viewBuildError.php?buildid=1344742), maybe you could give it a try to fix it.

OK thank you. Then I need to compile modules and extensions for instance SlicerJupyter and manually add it to Slicer, yes? Is QtWebEngineProcess only need to Extension Manager?

Yes, exactly.

You can find extension source code repository URLs in the ExtensionsIndex: https://github.com/Slicer/ExtensionsIndex

Works like a charm!
Ubuntu 16.04 on Docker.

I have installed two libraries:
sudo apt-get install libicu-dev
sudo apt-get install uuid-dev

I know that is a way that I should add this libraries to compile time only but I have created environment on Docker.

It’s amazing. We will save a lot of time on scientific work.
Thank you Kitware!

SlicerJupyter

Edit: autocompletion/hints doesn’t work here. I don’t know if it works for someone?

1 Like

A post was split to a new topic: Error running pip install

We are working out some remaining issues with auto-compleiton. It should be available within a few days.