Crash after returning from hybernation

This happened to me in MacOS, Linux and Windows. After returning from hybernation Slicer crashes when making any operation. In MacOS it reports this

Process:               Slicer [1737]
Path:                  /Applications/
Identifier:            Slicer
Version:               ??? (4.11.0-2020-06-03)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Slicer [1737]
User ID:               501

Date/Time:             2020-08-05 10:14:44.294 +0200
OS Version:            Mac OS X 10.15.5 (19F101)
Report Version:        12
Bridge OS Version:     4.5 (17P5300)
Anonymous UUID:        091E1568-436C-6B92-129A-4DD230D034BF

Sleep/Wake UUID:       171BF89F-38DE-47B2-8D4E-F941C324DE4D

Time Awake Since Boot: 3700000 seconds
Time Since Wake:       3500000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       EXC_I386_GPFLT
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [1737]

To reproduce Open Slicer, load some heavy scene (at least a 500MB mrb), do some operations, go to hybernation and wake up the computer. Then try to do some operation, Slicer will crash.

Interesting - I’ve never experienced this. I often have slicer running when I shut the lid of a mac laptop and everything starts back up normally. @lassoan do you see this on windows? @jcfr do you see it on linux?

What Slicer versions have you seen this with?

I am on MacOS 10.15
Slicer nightly 2020-06-03

But also happened in Windows 10 and in Manjaro Linux.
I usually leave the computer on during the night, and when I wake up this happens

I work from a laptop all the time and never turn it off and I have never experienced this. However, I use default power options, which puts the computer into “sleep” and not hibernate. I don’t even see a hibernation option in power settings.

Since waking up from sleep is much faster, does not consume precious SSD space, and that is the default on modern laptops (at least on Windows), drivers does not get tested widely in hibernation mode. I would guess it is a graphics or network driver problem, maybe a bug in Qt or QWebEngine (Google Chromium).

I cannot investigate this, because I would not like to mess up power settings on my laptop by trying to force display of hibernation option (I would assume that hibernation option is not offered for a good reason).

You can try latest Slicer, which uses a more recent Qt version, to see if it makes a difference.

I do use the hibernation on windows 10 (which I had to explicitly enable through command line, powercfg /h), because I would find my computer woke up from sleep from a background process (like virus check) and then used all the battery during travel. The point is though I never encountered this crash, after waking up from hibernation and using it with large datasets…

1 Like

As another datapoint, I suspended a docker instance of slicer and it resumed with no problems (debian image).

tried with current nightly on manjaro linux and seems to be resolved. I will try tomorrow with macos

1 Like

Tried in a Windows machine and seems to be solved, no more chashes.

Currently testing on MacOS.

1 Like

Tried on MacOS. Everything seems solved now. I will report if it happens again. Current version is being stable the whole day, no crashes so far.

BTW, my mac version is installed using brew so it is currently 2020-08-04