Crash when initializing app built and run from Ubuntu 20.04


so I still have this problem:

qt5ct: using qt5ct plugin
error: [/home/zolal/Slicer/Slicer-build/bin/./SlicerApp-real] exit abnormally - Report the problem.

Now, when I try the following:


Slicer runs!

Now, I have tried various other solutions proposed here in the forum, inclusive disabling Python SSL, but that was not so successful.
So I guess the problem is with QT, any idea how to get nearer to the issue?

Can you get a stack trace?
Maybe it is the same issue as this: qt5ct / Tickets / #77 Krita crashes with qt5ct plugin with Qt5.15


Somehow I do not understand what all the EAGAIN resource not available means. Is this the problem?

This file seems to be list of system calls. It is somewhat interesting, but the stack trace could be more informative. Could you print that, too?

So, one would think that strace will produce the stacktrace and not a trace of system calls, right? :slight_smile:

Now. I tried with gdb, maybe this will help someone:

gdb ./Slicer 2>&1 | tee ~/gdb-Slicer.txt
(gdb) handle SIG33 pass nostop noprint
Signal Stop Print Pass to program Description
SIG33 No No Yes Real-time event 33
(gdb) set pagination 0
(gdb) set follow-fork-mode child
(gdb) run
Starting program: /home/zolal/Slicer/Slicer-build/Slicer
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/”.
[New Thread 0x7ffff6e35700 (LWP 96055)]
[Attaching after Thread 0x7ffff7622140 (LWP 96054) fork to child process 96056]
[New inferior 2 (process 96056)]
[Detaching after fork from parent process 96054]
[Inferior 1 (process 96054) detached]
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/”.
process 96056 is executing new program: /home/zolal/Slicer/Slicer-build/bin/SlicerApp-real
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/”.
[New Thread 0x7fffd5473700 (LWP 96059)]
qt5ct: using qt5ct plugin
[New Thread 0x7fffcffff700 (LWP 96060)]
[New Thread 0x7fffce9bb700 (LWP 96062)]
[New Thread 0x7fffce1ba700 (LWP 96063)]
[New Thread 0x7fffcd9b9700 (LWP 96064)]
[New Thread 0x7fffcd1b8700 (LWP 96065)]
[New Thread 0x7fffcc9b7700 (LWP 96066)]
[New Thread 0x7fffb7fff700 (LWP 96067)]
[New Thread 0x7fffb3abe700 (LWP 96085)]
[New Thread 0x7fffb2e8d700 (LWP 96086)]
[New Thread 0x7fffb1aff700 (LWP 96087)]
[New Thread 0x7fffb12fe700 (LWP 96088)]

Thread 2.1 “SlicerApp-real” received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd6406d40 (LWP 96056)]
0x00007fffe6275d71 in ?? () from /lib/x86_64-linux-gnu/

another funny thing:

running sudo ./Slicer works!!

qmake --version
QMake version 3.1
Using Qt version 5.12.8 in /usr/lib/x86_64-linux-gnu

Somehow I am getting the feeling that this might be related to the fact that my laptop was upgraded from 16.04 -> 18.04 -> 20.04 like in the case of the other user and maybe there is a bug in updating Qt.

Yes, if sudo works then it suggests that the root cause may be some incorrectly permissions.

For future reference: the build using the default Qt version did not work (Qt version 5.12.8 in /usr/lib/x86_64-linux-gnu).

After installing Qt from Qt website using the online installer (with all modules! not the default option, because in default you will miss QtScript etc.) use cmake like this:

cmake -DCMAKE_BUILD_TYPE:STRING=Release -DQt5_DIR=/opt/Qt/5.15.2/gcc_64/lib/cmake/Qt5 …/SlicerSource/

Then make, naturally.
Slicer runs without problems now.

1 Like

Thanks for the update. Do you think we should include a note about this in the Slicer build instructions or yours was a very special case?

Hi, I think that before you get more similar reports, this was a special case.