Cutting model with planes using dynamic modeler

I am relatively new to slicer beginning to test out the features to use in my research project. So far I was able to get by with information I found in this forum or the wiki. But I got to a point that I am stuck. My goal is to divide a 3D model of periatrial fat into regions with regard to the adjacent left atrial wall by drawing planes and calculate the partial volumes.

Operating system: Win 10
Slicer version: 4.11.20200930
Expected behavior: cutting a 3D Model with multiple planes through the dynamic modeler feature to create separate model parts.
Actual behavior: nothing seems to be happening after selecting model node and plane nodes; trying different parameter and output node options.
This is how it looks:

I would really appreciate any help in this regard to point out any things I am missing.

By default Dynamic modeler is giving the output as the same color as the original model. So it might be working fine and you might not be noticing anything until you actually go to Data module and check the output and change the colors.

Right after the apply the cut, it looks like this:

But when I set the colors of different cuts, i can see them (you can see the original model bleeding through the cuts as yellow):

Thank you very much for your answer. You are right about the color behavior of the models. The models are generated in the Data section but changing colors does not yield a result as in your case, unfortunately.


Have you tried checking the properties of the output models (Model_2 and Model_3)? This might help narrow down the issue. In the Models menu under ‘Information’ you can check the number of points and cells.

Thank you for your input. I checked the properties of my models, strangely the 3D Fat model I was using had no Information (blank fields) the same was true for the generated Model2, Model3.
I loaded my fat model .vtk again (which than displayed properties values) and again used the dynamic modeler (trying all possible settings like union, intersection…) to generate the new models, with the same result (properties remain blank / models not visible)

You can check the log file (Ctrl + 0) to see if there are any errors generated by the module. Alternatively, try other modes of operation and see if it is unique to the difference mode.

I found the problem with your help. I suppose the problem somehow was that my first model had a problem with the “properties being missing”. After loading it again, at first I did not delete my “plane cut”. But after going through the whole process again (loading .vtk model and creating new planes and a new “plane cut” in the dynamic modeler, it worked.

Thank you both.

1 Like