Designer will not load with slicer widgets


(Robin Holmes) #1

Operating system: ubuntu 18.04
Slicer version: 4.11.0
Expected behavior: designer loads slicer widgets after build
Actual behavior: exits with error message - this function is deprecated. Use currentNodeID() instead. qMRMLNodeComboBox::basename failed

I built slicer today, but needed to alter a line in libarchive/archive_pack_dev.c as per the post from phcerdan.

When running ./Slicer --designer I get the error above. I have tried copying the various plugins to the designer directory and that enables me to run designer with most of the widgets - if I copy libqMRMLWidgetsPlugins.so it crashes with the same error.

Many thanks - Robin


(Andras Lasso) #2

Do you get an error if you just launch ./Slicer --designer without loading any .ui file?
Can you post a screenshot so that we can see what displays the error message and where?


(Robin Holmes) #3

Thanks for the reply. I have attached a screenshot showing the error message after launching ./Slicer --designer.


(Andras Lasso) #4

It seems that you’ve built Qt designer in debug mode. Debug-mode builds are often forced to crash by assert calls when some consistency checks fail. This problem will not occur with a designer built in Release mode and I believe this is what most people are using. To fix the debug-mode designer, we should probably change the assert in ctkMatrixWidget.cpp, line 241. We’ll change this in CTK, too (I’ve already submitted a pull request).


(Robin Holmes) #5

Brilliant - I have had success in Release mode. Many thanks for your help.