Display a segmented data in Slicer 3D view

Operating system:win 10
Slicer version:4.10
Expected behavior:
Actual behavior:

Hi,everyone.

I would like to know" Is it possible to display a segmented data with " nrrd " format in slicer 3D view ?".
Here " segmented data" means , it is not segmented by slicer (i didn’t use the " Segment Editor " module to do this work.) The below pic shows how my " segmented data" looks like( i open it with ITK-SNAP):

Black pixel value 0
Grey pixel value 1
White pixel value 2

There are 3 parts basically.

I noticed some differences when i do the segmentation work with slicer(using "Segment editor ") as well as without slicer (using my own method to obtain segmented results).

With slicer , i can oabtain results with the following pic, we can see the segmented result is the “Segmentation.seg.nrrd” file and " iDose (1) Processed-SimpleITK.nrrd" is the voulme data.

image

Without slicer, i have the following files, " idose(1)-wxy.nrrd" is the volume data , “Segment_1.nrrd” is my " segmented data".
image

Then ,here is my question, how am i able to convert “Segment_1.nrrd” to “Segment_1.Seg.nrrd”( i guess the data should be in “.Seg.nrrd” format for all the segmented data to correctly display in slicer views ),so i can display my " segmented data" correctly in slicer view.

Is there anything i can do to achieve this goal ?

Any help would be appreciated.

You can load ITKSnap segmentation as labelmap then convert it to segmentation:

  • Use “Add data” dialog, click on “Show options”, check “labelmap” checkbox, click OK
  • Go to “Data” module, right-click on the labelmap volume, and choose “Convert labelmap to segmentation node”

Segmentation is saved as a 4D nrrd file. If your segments don’t overlap each other then you can export them as a single 3D merged labelmap and save that:

  • Go to “Data” module, right-click on the segmentation node, and choose “Export visible segments to binary labelmap”
  • Use “Save data” to save the exported labelmap to .nrrd file
2 Likes

Thank you so much @lassoan.