display incorrectly when two volume rendering by3D slicer 4.10.0

Problem report for Slicer 4.10.0 win-amd64: [please describe expected and actual behavior]
Problem report for Slicer 4.10.0 win-amd64: [please describe expected and actual behavior]
the 3d slicer 4.10.0 can render two volumes at same time. It is really important function for me. But when I use this function, I find the display is not correctly.My setting is following:
1,OS:windows 10 professional X64 with latest update;
2, 3D slicer version:4.10.0 released and 4.11.0 nightly.
3, data: CTchest.
4, input two CTchest volumes . first volume use preset"CT-lung" and the second use “CT-AAA”.And then let these two volumes display in one windows.
5,problem: the lung should be around by rips.But when rotate the sense ,the lung is always on foreground . The rips can not be displayed correctly. the snapshot is attached:
twovolumes%20render

For multiple visible volumes you need to use the new rendering mode:

image

Should be:

image

1 Like

Multi-volume renderer currently does not support shading, so the images will not look surface-like. Until this feature is implemented, you can segment all additional structures using Segment editor module and show them in 3D. Some structures, such as bones and devices should be easy to segment (using threshold effect, optionally followed by some smoothing, cutting, etc.), while others might be more difficult.

@pieper @lassoan
thanks to response. Now dispaly is correct when rendering change to VTK Multi-Volume(experimental).And it is pretty work for me.Thanks for all developers! But the rendering quality is different between "VTK multi-volume(experimental) " and “VTK-GPU ray casting”. I think “VTK-GPU ray casting” is better .

rendering by VTK multi-volume(experimental) :
VTK%20multi-volume%EF%BC%88experimental%EF%BC%89

rendering by VTK-GPU ray casting:

VTK%20GPUray%20Casting