Draw tube for vessel segmentation: does not show

Hi there!

I’ve been trying to work with Draw tube tool for a while. I’m currently working on vessel segmentation, and my goal is to draw a tube in those areas where there is a blood vessel, but the segmentation on the 3D model is incomplete.

However, when I add the fiducials and click apply, it does not show on the model. I noticed that this only happens when I add the fiducial on my model. If I place fiducials in a space not occupied by the model, the tube appears just fine.

How can I solve this?

Thank you in advance!

Here you have some images before and after clicking Apply

I suggest you read this small part of the documentation:

You’ll see that when you draw something within another segment using the current options, it will overwrite the existing segment. And since you use the same color, you can’t see it at all. Depending on your use case, either use a different color, or allow overlaps.