Elastix fails to update resampled image and transform

I am using a downloaded Slicer 4.9.0-2018-05-04 r27180. Using sample data MRBrainTumor1 and MRBrainTumor2, I try to register them using SlicerElastix extension. I tried a couple of presets (3D MRI, monomodal (brain) among them), but that doesn’t seem to matter. After registration is finished:

Volume registration is started in working directory: C:/Temp/User/Slicer/Elastix/20180523_093922_751
Register volumes...
Generate output...
Registration is completed

Nothing looks changed. If I try to save the scene, the transform and resampled volume are not selected by default, meaning they are empty nodes.

If I go to the temp folder and load the intermediate images (e.g. result.hdr), they are correctly resampled. Can anyone confirm this?

It works well for me with “generic (all)” preset? Have you tried with that?

generic (all) and generic (rigid) do work now, but I could have sworn they didn’t work earlier today. 3D MRI, monomodal (brain) does not work in repeated tests. This applies both to 4.9.0-2018-05-04 r27180 and today’s nightly.

@Andinet_Enquobahrie was able to reproduce this on his computer. I submitted an issue.

Issue fixed (input file format in the parameter file was set incorrect), should work in tomorrow’s nightly build.


I tested it. it looks good. Thanks for fixing it. -Andinet

1 Like