Error writing settings on MacOS

My slicer cannot save any settings I try to change, even its basic ones. I tried to give it the whole disk permissions, but still nothing. All I can see in console is:
[Qt] Error #1 while writing setting “ApplicationUpdate/AutoUpdateCheck”
[Qt] Error #1 while writing setting “ApplicationUpdate/ServerUrl”
[Qt] Error #1 while writing setting “DefaultScenePath”

and such things like for 50 settings.
I’d appreciate any help, hope someone already faced this porblem. Thanks.

Doesn’t happen for me on macs I use. Be sure you’ve installed the app (not running from the disk image) and that your home directory isn’t full or otherwise unavailable.

Thank you for yourreply. Even tried to install with homebrew. Any possibilities to intall not in applications folder but, for example ~/user/slicer/?

Yes, you can install the applications anywhere you want.

For me the settings are in ~/.config/ so you might check if that exists or is somehow locked. Perhaps it got set to read-only and or you need to delete a corrupted one.

It worked! Just needed to find .config and change writing permissions. I’m kinda new to mac (less than a month) so it was a bit complicated. Thank you!