Errors Running Slicer on CentOS using X11

Got Slicer 4.11 installed on a CentOS remote machine mainly to be used for processing. It was working fine the first week, but something seems to have happened in between, or we didn’t notice what was up then.

Ideally we’ll be running Slicer with the --no-main-window and --no-splash flag and using a --python-script to do our processing, but when I try running Slicer by itself I get the following errors:

The splash window does pop up, and modules are loaded, and then it tries to show the welcome module, but all I get is this on the command line

After a while of this, Slicer GUI screen container pops up, but it’s empty and the command line repeats the same error over and over:

I tried looking into the initial libGL errors, and I can find swrast on the machine. I can’t find the fbConfigs or visuals the command line is talking about. I tried finding the OpenGL version but have been unlucky.
And I have no idea what happened next or how to fix it.

Do anyone have tips on how I can install and run Slicer on a CentOs machine? Everything in the processing pipeline with the extension works and this is the last step where things are going wrong.

Does other OpenGL applications, such as the standard glxgears demo work on your computer?

It does not. I get the following errors

If you are running no-main-window anyway you can use Xdummy or xvfb to fake the connection.

You are using a X11 server that doesn’t support GLX extension that is required to run openGL libraries on X11 clients.

If you don’t need the GUI, @pieper’s suggestions should work. If you eventually need the GUI, VirtualGL ( works really well on centos 7 (I haven’t tested 8 yet).

Don’t need a GUI in the end, so I’ll check out Xdummy and xvfb! Thanks for the recommendations.