Final thresholding result looks more pixelated than preview

Operating system: win 7
Slicer version:12-2
Expected behavior:
Actual behavior:2017-12-04_2110382017-12-04_211052

The picture looks rough and serrated after Apply…why?

Segmentation happens at pixel resolution but the preview is shown at screen resolution. If you need higher resolution you could upsample the master volume first. But smoothing is applied when you build models, so typically working at the native resolution of the scan is the best place to start.

1 Like

Thank you Steve Pieper for your replay.
However, I had the same resolution in MIMICS software(below pictures).
I couldnot understand “upsample the master volume first”, what should I do in 3d-slicer to get the same result between final thresholding and preview.
Thanks.

2017-12-10_2136432017-12-10_213656

To be able to represent smaller details, do as Steve suggested, increase the input volume resolution using Crop Volume module’s interpolation option. I would also recommend to set isotropic voxel size.

If you just need smoother model, then you may try Smoothing effect after thresholding and tune mesh generation smoothing (click small “down arrow” on the 3D button).