Generate a 3D reconstruction from histology sections

What I ultimately want to do is create a 3D reconstruction of structure from histology sections. I have imaged the H&E slides and aligned them using TrakEM2 on Fiji, and saved the files individually as TIFF files. When I open the images on Slicer, they are loaded separately and not as one volume.

Others on this forum have asked this question and the solution has been the following:

  1. Click on “Add Data”
  2. Select one of the image
  3. Click “Option” -> Uncheck “Single File”

However, when I try this, it still does not work.

I would appreciate any help in this matter. Many thanks.

1 Like

I have a very similar problem, using Fiji and Slicer.

1 Like

The files need to have exactly the same size and named similarly (e.g., image_001, image_002,…). If you still have issues loading files then upload somewhere and copy-paste the link here so that we can try, too.


That worked! Thank you Andras. You’re the man.

1 Like

Andreas for president. Worked for everything as well, thanks.


After I segment all the slides, what is the best way to create a 3-D model?

I tried the “show 3-d” button but the 3-d rendering is not displayed inside the pink box making it difficult to visualize the rendering. Also, it seems like the 3-d rendering is flat so I think I need to input section thickness and distance between slices somewhere, but not sure where.

Thank you!

1 Like

Click on crosshair icon (“Center the 3D view…”) right above the 3D view to reset the box size and position.

That’s why people who work with 3D imaging don’t use TIFF and similar file formats. TIFF images don’t have a standard way of storing spacing between slices. Anyway, you can specify the correct spacing value in Volumes module “Volume information” section.

1 Like

I know using TIFF images is not ideal, but I only have H&E slides and don’t know any other way of creating a 3D reconstruction from these slides.

I have tried the “volume information” tab, but it does not seem to be working for the following reasons:

  1. In “volume information”, under “active volume” I am only given the option of choosing one of the tiff images. Should I be able to choose the 3-d segmentation I have created?
  2. When I try changing the image spacing distances, it does not change my 3-d rendering. It only manipulates the selected images.
  3. Can I input the thickness of each image?

Thank you.

When you import your image stack you must select only the first file and uncheck the Single File option. That way slices will be read into a single volume.

If I choose the first file, how do I upload the rest of the images?
EDIT: Nevermind, figured this out.

I am still having trouble with the following:

  1. When I try changing the image spacing distances, the 3-d rendering does not change. It only causes distortion of the selected images in the red box. The distance between each section is 100 microns so where exactly do I input this value as there are 3 options for “image spacing.”
  2. I want to segment all the images and then interpolate the volume between each section (ie interpolate the 100microns between each segment). How do I accomplish this?

Thank you for all the help. Much appreciated it.

There are three values for image spacing because there are three dimensions. Your 100 micron is your slicer thickness so it goes to the z value (last field). For xy dimensions you need to measure the width of your slides and divide it by the number of pixels
in in your image (unless you have rectangular pixels for some reason, you can do this only for x dimension and enter she value for the first two boxes).


Get Outlook for Android