Generating an opaque volume using volume rendering

I have a volume which contains continuous measures of depth and I want an opaque 3D volume rendering. I have thresholded the volume (in the volume module), to remove the background and have used “synchronize with volumes module” in Volume Rendering. However, when I try to adjust the “scalar opacity mapping” it turn the whole volume dark blue.

Operating system: Ubantu
Slicer version: 4.10.2
Expected behavior: opaque 3D volume displaying different depths
Actual behavior: dark blue opaque volume or transparent volume with correct colours

You will always have near-zero values at the edge of the volume, so if you make the opaque then they will occlude all the other colors.

Since you want to display a surface, a surface rendering is more appropriate: faster, higher quality, and you can of course make it opaque without any problems. To render a colored surface:

  • export the segment to model
  • use “Probe volume with model” module to add a scalar containing the volume’s voxel values
  • use Models module Scalars section to enable scalar display, choose colormap, range, optionally threshold