Heart segmentation

Operating system: windows 10
Slicer version: 4.1.10
Expected behavior:
Actual behavior:
how can i prevent merging of hollow shells (F1) like in the image. Also is there away i can reduce size of brush tool below 1% as sometimes i try to erase stuff between two closely placed structures. I am trying to create 3d models of heart but these issues prevent true representation.Capture1

Thanks,
Sarv

There are two ways to separate falsely connected chambers:

Option A: Separate the touching parts. If you used simple thresholding then you have to go and erase connecting region slice by slice (you’ll have less falsely connected chambers if you use a lower threshold value). If you use grow from seeds then you can place a small seed in between and it will be grown in 3D. I’ve implemented masking in Grow from seeds effect just now (will be available in tomorrow’s nightly version), which should make such separations easier to do.

Option B: Make each chamber a different segment and hollow them one by one. This will create a shell around each chamber, so you need to create openings (using Erase or Scissors effect) where there should be opening (where there is a hole or valve).

Thanks Andrass

I had used threshold method. I am trying to erase slice by slice but as I mentioned since the size of brush doesn’t go less than 1% I end up erasing more than I want to.

Also what is this masking in grow from seeds and how will this work.

Thanks

Sarv

Brush size is relative to the screen. Zoom in the image more if the smallest brush size is still too large.

Thanks a lot Andras.

Sarv