How to instal old version of extension from file

I want to install the version of total segmentator of 3DSlicer 5.4 to have access to the “liver vessel” task
I found a branch on the github repository named 5.4 and downloaded the code
I then opened the extension manager on slicer 5.4 and clicked on “install from file”
However I can’t find the “extension file” in the code.

I think there’s something to do to generate the “extension file” from the code but I don’t know what.
I’ve never installed an extension from a file so I might be missing something obvious.

If you are installing from an extension from a cloned github repo, I find that Extension Wizard works better than “install from file”. Click Select Extension and then navigate to the root of the repo.

It worked thank you so much :smile:

1 Like

I wanted to try v2 while using totalsegmentator v1 and I couldn’t get rid of the “returned non-zero exit status 120” error. I want to try the old version like you did. I couldn’t find the old version on Github, I didn’t understand the solution here, where exactly is the extension wizard? I’m not very good at code but I think I can handle it with a little help, thank you

To try V2 you need Slicer 5.6
I think that if you have this version and install total segmentator from the extension manager you will get V2
On my computer, I have two slicer installed 5.4 for V1 and 5.6 for V2

I am using 5.4 slicer, how can I access v1?

The way I did it is that I downloaded the code of the extension for slicer 5.4 there GitHub - lassoan/SlicerTotalSegmentator at 5.4

Then I used the extension wizard to search for it and add it to my slicer set up

Be carefull to not stock the files with a path that contains special caracter (é, space, ö,…)

Even if this work, it’s not perfect and I would recommend to use total segmentator V2 with slicer 5.6 exept if you have a reason to do otherwise

Is there a reason you all are not using the Extensions Manager in Slicer 5.4 to install SlicerTotalSegmentator? That will get the Slicer 5.4 version of extensions.

I tried but it wasn’t working
Is it possible that some dependency of totalsegmentator are updated past version 5.4 which causes the issue ?

It may also be because of my set up since I have totalsegmentator already installed on my PC and use it outside of 3Dslicer. It has already been a source of issue.

thank you very much, I tried many things and somehow I succeeded. I can use totalsegmentator v1 in Slicer 5.4 as before

1 Like