How to use Resample Scalar/Vector/DWI Volume

I’m trying to resample a volume with the “Resample Scalar/Vector/DWI Volume” module.

However, the output is cropped, so I must be doing something wrong.

The only three things that I’m changing are ‘Input volume,’ ‘Output Volume,’ and ‘Spacing’ (the last one I set to 0.5,0.5,0.5)

That’s the scene before applying the resampling:

And that’s the scene after hitting ‘Apply’

If you use the low-level API of the module to specifying image geometry manually then you need to set all parameters (origin, spacing, axis directions).

Usually the output geometry is set by choosing a Reference volume - the resampled volume will have the exact same geometry as the reference volume.

If you don’t have a reference volume then you can use Crop volume module to compute the image geometry. The module sets the image geometry based on the ROI box, the Spacing scale value, and Isotropic spacing flag. The module uses Resample Scalar/Vector/DWI Volume module internally for the resampling.