'imageio' no longer found in site-packages on fresh install

Hello, I have been working on a project that uses Slicer to help rasterize an .stl file to a TIFF stack of images. This process is aided by a very similar python script like this in the documentation. Recently I reinstalled Slicer and now I am getting an error stating: ModuleNotFoundError: No module named ‘imageio’

I have Slicer also installed on another machine, and within the Lib\site-packages there is an imageio file within the directory, while on my machine (the one I am having issues with) there is no imageio in the directory.

I have also tried to use Slicer’s python console using import imageio, but I get the same exception.

Has Slicer dropped the use of imageio with the use of python? If not is there a way to fix this error?

From my memory, imageio has never been included in Slicer core. It was likely installed in Slicer whenever you installed an extension. Something like scikit-image uses that python package as a dependency.

To install additional python packages in a Slicer version, see the following documentation:


Hey James, I actually fixed this shortly after I posted this. Along the lines of development, I think I ran pip_install(‘imageio’) at some point and forgot like a goofball. That link you sent is essentially the solution I came to. Thank you for your help!

1 Like