Is it possible to edit the ImageOrientationPatient DICOM tag in slicer?


I am hoping it is possible to edit the ImageOrientationPatient DICOM tag and associated image within Slicer.

My problem,

I have a CT image which has been transformed with 6 degrees of freedom (3 Translations and 3 Rotations), hence, its ImageOrientationPatient DICOM tag has gone from [1;0;0;0;1;0] to [0.9998;0.0189;0.0056;-0.0189;0.9998;-0.0056]

I want to dose a dose calculation on the transformed CT, however, my treatment planning system does not allow dose calculations on tilted images. Is there a way I can correct the ImageOrientationPatient DICOM tag back to [1;0;0;0;1;0] within Slicer? This would also be required for the radiotherapy structures DICOM file too

Many thanks!!

I don’t think this can be done within Slicer, but there are command line tools that can edit headers.

As you are likely aware, extreme caution, prudence, and oversight should be exercised when integrating any non-standard modifications into a human clinical pipeline. Note that Slicer is not FDA approved (although some Slicer-based products could potentially be – with liability assumed by the providing commercial entity). The open source Slicer license explicitly disclaims liability for clinical use.

Actually, Slicer can solve this. Correct loading of tilted-gantry images has been recently added. You have to enable application of an acquisition transform in Application Settings / DICOM section. Then:

  • load the volume from DICOM
  • go to Transforms module and “harden” on the acquisition transform on the volume
  • go to Data module and right-click on the volume to export to DICOM

Gantry-tilted acquisitions are quite rare and so this feature is not tested extensively, but it should work. Let us know if you have any issues.


Thank you kindly for your reply! Much appreciated!

Hi Andras,

I have tried the approach you suggested above but seem to be having difficulty. I am using Slice version 4.8.1

To confirm, this is what I have done,

  1. Open Slicer, go to Edit > Application Settings. Then under the DICOM section I changed the Acquisition geometry regularization field to ‘apply regularization transform’
  2. Imported my tilted CT volume. Note the gantry isn’t tilted but the treatment couch is, leading to a non-[1;0;0;0;1;0] value for ImageOrientationPatient
  3. Went to the Transforms module, but there is no ‘acquisition transform’ to harden
  4. I tried hardening a new transform, but after exporting the DICOM CT volume is still tilted

Any suggestions would be fantastic!

EDIT: I have found that for some patient data, I am indeed able to harden the ‘deformed image export acquisition transform’. However, once I export this, my treatment planning system still registers a tilted image


If gantry was not tilted then it is even simpler: save your data set as .nrrd file, then load the .nrrd file - but before clicking OK in “Add data…” dialog check “Show options” checkbox and check “Ignore Orientation” checkbox.

1 Like