"Keep only whole cells when clipping" not saved in mrml scene file

This is somewhat relevant to Clipping of models is too slow.

Enabling “Keep only whole cells when clipping” speeds up the clipping a lot for complex models. This setting, however, is not saved in the scene file, making scene loading very slow for complex projects saved with clipping enabled.

Is there a way to add this? Happy to give it a shot if someone could point me in the right direction on where to start.



Oops, make that Window resize with model clipping enabled is extremely slow as the more relevant post. Sorry about that.

Good catch. I’ve fixed the scene reader now. The fix will be available in the Slicer Preview Release that you download on Friday or later.

1 Like

Awesome - thanks a lot!!!