Limitation in increasing the resolution in Crop Volume module

Operating system: Windows 10
Slicer version: 4.10.1 and 4.10.2

Hi all,

I want to increase the resolution of CT scans in the crop volume module. I have cropped the original scan with my selected ROI and I haven’t applied any interpolation (let’s call this volume as the “cropped scan”). I am trying to increase the resolution of the cropped scan. So, I have the cropped scan as input and I use the “Spacing scale” of 0.25. The problem is that after pressing “apply” everything seems normal but when I checked the scan’s resolution in the “Data” module, I realized that the output scan has exactly the same dimension and spacing as the cropped scan. I have checked the spacing scale of 0.5 and it works fine. This means that I cannot increase the resolution with a spacing scale of less than 0.5. Would you please let me know why I face such a problem and how I can fix it? I have tried the same procedure on two different PCs and I see the same behavior on both.

This increases memory usage by 4x4x4 = by a factor of 64x. If you started out with a 200MB volume, the required amount of RAM was 2GB. To be able to resample with spacing scale of 0.25, you would need 128GB of RAM. So, most likely you have run out of memory.

There are several solutions:

  • not just resample but also crop the volume to a smaller region
  • increase virtual memory/swap size in system settings
  • add more physical RAM to your computer
  • choose a larger spacing scale