Loading Tiff Stack

Issue 1:
I am not sure why I keep having the same issue, but I was hoping you might be able to point me in the right direction. I am trying to load this file: [http://www.morphosource.org/Detail/MediaDetail/Show/media_id/18864]

Question3. It is a .tiff stack. I load it in and then change the spacing to reflect the scan parameters. Every time I do, the skull ends up having these weird spaces… do you know what I am doing wrong? It looks fine as long as I don’t try to input the scan parameters. Morphosource is offline right now so it may not be possible to access the original file. Could it be I doing something wrong in the upload process? Or could it possibly be a greyscale issue?

Issue 2:
For my files that are DICOM stacks, I was using the ROI function to clip the volume (so I could see endocranially). It isn’t working when I use a .tiff stack… is there a comparable function that I can use?

Operating system: Windows
Slicer version: Slicer 4.13.0-2020-12-11
Expected behavior: Volume loads without weird spaces
Actual behavior: Volume loads with spaces in the volume

This looks like a rendering issue, in which shading is not working correctly. Can you provide a screenshot of your “Volume Rendering” panel?

Couple other things:
Are you by any chance using “GPU MultiVolumeRendering”, which is an experimental feature? Can you try choosing “CPU Rendering”. It will be slow, but should render correctly.
Also what’s the GPU (graphic card) in your computer and the driver version?

Since MorphoSource is currently offline, I can’t download and try the dataset.

It looks like the volume renderer sampling is too sparse. You can try setting spacing to 0.1 in Volumes module (Volume Information section) and/or in Volume rendering module, use GPU volume rendering and change rendering quality to “Normal”. Splitting the volume to two smaller volumes that only contain one piece may also help.

It was on GPU MultiVolumeRendering on accident… I changed it back to GPU Rendering and now it is working again! (The ROI feature is now working again as well!). Thank you.

Great to hear that. But can you actually change the solution, so that it was tagged correctly? It wasn’t the spacing that Andras suggested (which is what you chose as the final solution).

Sorry… it should be fixed now.

1 Like