Lung CT segmenter

Operation system: Windows 10
Slcier version: 4.11 20210226

I tried to run the Lung CT segmenter module on a dog CT series.
Preview was ok but after applying I got this error message:
Saving fiducials in root directory …
Saving fiducials in volume directory …
Failed to compute results: expected str, bytes or os.PathLike object, not NoneType
Traceback (most recent call last):
File “C:/Users/petnehazyors/AppData/Local/NA-MIC/Slicer 4.11.20210226/NA-MIC/Extensions-29738/LungCTAnalyzer/lib/Slicer-4.11/qt-scripted-modules/”, line 397, in onApplyButton
File “C:/Users/petnehazyors/AppData/Local/NA-MIC/Slicer 4.11.20210226/NA-MIC/Extensions-29738/LungCTAnalyzer/lib/Slicer-4.11/qt-scripted-modules/”, line 465, in saveFiducialsGlobalAndLocal
baseFolder, tail = os.path.split(inputFilename)
File “C:/Users/petnehazyors/AppData/Local/NA-MIC/Slicer 4.11.20210226/bin/…/lib/Python/Lib\”, line 205, in split
p = os.fspath(p)
TypeError: expected str, bytes or os.PathLike object, not NoneType

Where was the problem and how can I solve it?

Thank you in advance

The error message suggests that maybe empty path was given? I guess not, but double-checking (looking at the log you were kind to paste, it seems it got past the first round of saving). Is this module available for the latest Preview version (almost 5.0 so time to try to switch)? If so, does the error occur in that as well? Thanks!

Dear Csaba,

Thank you for the answer. I ran into another problem trying to download the latest version. It is not possible to download it…



Csaba Pinter via 3D Slicer Community <> ezt írta (időpont: 2022. jan. 17., H, 14:37):

Thanks for your report.

I just tested the LungCTSegmenter and do not get this exception when loading a CT dataset from my local harddrive.
In your case, inputFilename is obviosly empty for some reason and so the exception is thrown.
Will try to fix this, but:

How did you load the CT data?
What version does LungCTAnalyzer show on your system ?

How did you try to download it?
I have no problem installing the LungCTAnalyzer extension from the Extensions Manager in 4.11.
Could you provide more details?

Dear Rudolf,

I tried to download the Slicer latest release and this didn’t work.



Rudolf Bumm via 3D Slicer Community <> ezt írta (időpont: 2022. jan. 18., K, 9:46):

Dear Rudolf,

I’ve found the solution for the Lung CT segmenter problem based on your comment. The problem was:

  1. I downloaded from our server a series with Radiant
  2. Radiant put 2 series from 2 separate dogs in 1 folder.
  3. Slicer recognized this as two separate examinations
  4. The original folder didn’t contain any information with the same name as Slicer recognised the series.

Now I separated the series and made the folders with the appropriate names and it works.

Thank you for the suggestion!

Best regards,


Rudolf Bumm via 3D Slicer Community <> ezt írta (időpont: 2022. jan. 18., K, 9:43):

1 Like

Click one of the preview release buttons, download is starting here without problems …

Your problem will probably be unrelated to these Slicer versions because LungCTAnalyzer works in both stable and preview release.

1 Like

Great, I have implemented a small change in the LungCTSegmenter and -Analyzer source (V2.46) to avoid the exception in the future.