Merging different DICOM files together

I have imported a series of DICOM files “a skull”, but it shows just all slides seperated. How can I merge them?![Screenshot01|690x376](upload://jHLyIQxSvtlOjuUgvIRGScreenshot02 Uoy5ahW.png)

Thank you very much!

My CT scan is seperated into different dicom files. Everyone is a little layer. How can I merge them?
I use 4.8.1 on Windows 10.
Screenshot01
Screenshot02
Screenshot03

It is recommended to load all DICOM files by drag-and-dropping the folder (not a single file, not multiple files, but the parent folder) to the application screen then click OK in the popup to load directory into DICOM database. After importing is completed, you can load data sets into the scene using DICOM module.

Dear Mr Lasso, thank you very much for your reply. I have done exactly that, what you have described. But then nothing is loaded.

Screenshot01
Screenshot02
Screenshot03

Clear the DICOM database folder or choose a different DICOM folder and use latest nightly build of Slicer. It should all work correctly then.

If you have further issues then follow instructions on the DICOM FAQ page. If those instructions don’t help or you have other questions then feel free to post them here.

I solved the problem. I have to drag it as “AnyData” and then disselect “Single file”. This worked well with one test CT (34 pictures). But now I have a CT with 2300 pictures. I do not want to manually disselect all as “Single file”. Is there an easier way? Thx!

If you are going through the Add Data dialog, then just add one file from the series, uncheck SingleFile and it will find the others.

but the dicom suggestions @lassoan suggested are good too.

A post was split to a new topic: How to import cardiac MRI

Hi, I also have the same problem. However, I am so new to 3D slicer. Even after I read this thread, I still had no idea how I can merge the individual DICOM volumes. Can anyone give me some more detail about what to do next after all the DICOM files are loaded into the data base?

I am not sure whether the new version of 3D slicer change the interface. I finally figure it out by myself:
Just for green user like me
In the manual, click
“File” and then “Add data”. The “Single file” option will only shows up if you check the “show options” checkbox. Also, sometime because the size of the window, the “Sinle file” optiont taop is hiden behind other taps. You may need to stretch the window to see it.

BTW. I have another issue:

The loaded files are not sequenced based on the file name but the file location. Is it any way I can sort the DICOM files by the single image store inside, supposed that each DICOM only contains a single image?

FYI, we always recommend that you use the DICOM module for importing DICOM data to handle sorting and identification of different scan types at a higher level.

https://slicer.readthedocs.io/en/latest/user_guide/data_loading_and_saving.html#dicom-data

Hi, Pieper. Can you be more specific? If I used DICOM module, the DICOM files will load into 3D slicer as multiple independant nodes (or called volume?).

The DICOM files exported from our CT scanner only contain one instance for each DICOM file. I am new to this field and I am wondering if there is any way to sort the instances and combine them into a single DICOM database in 3D slicer. If so, how can I do it?

I’m not sure what kind of scanner you have - I guess a microCT, since they tend to be less careful with the dicom standard than clinical CT scanners. I suggest you try downloading some of the sample dicom datasets (e.g. this one, but there are many others available), load them into Slicer via the DICOM module, and see how things are supposed to work. Then if your data behaves differently you can look at the debugging suggestions I linked to earlier for ideas.