Model-to-Model Distance - How to see the Inside

I have two tooth models I am comparing. One of them has been drilled (YELLOW), while the other is in pristine condition (RED). I have aligned them using ALPACA and then used model-to-model distance extension to calculate the difference between the two models (GREEN/BLUE).

Expected: When reduced opacity, I should be able to see the difference inside the tooth.
Actual: Only the difference of the outside surface area can be seen via the colour map.

How can I adjust so that I can see not only the outside surface, but also the hollow inside difference?
Thanks in advance.

For the model of interest, in the “Display” section of the Models module, in the “3D Display” section, make sure that “Visible Sides” is set to “All”. If it is set to “Front” then only the outer surface is rendered and inner surfaces are invisible.

Once you do that, you might also try using the “Clipping Planes” section to get cut-away views.

The model to model surface will calculate the difference for each point on the source model. It looks like the tooth without drilling is the source model here? If this model has no interior structure, there will be no values on the interior. In this case, you might consider reversing the mapping and using the drilled tooth as the source model.

Thank you for your advice, however it is already set to all visible sides.

Thank you. I’ve swapped the two and I am getting a better result. However, I am still confused as in theory, the inside of the tooth should show red, not green as shown in the pic attached. The only difference between the two teeth is the hollow inside cavity.

Would you have any idea what’s going on here?

If this is the output from the ModelToModelDistance module, the colors will correspond to the signed or unsigned Hausdorff distance between the source and the target points (if you are using the signed or absolute closest point options in the module).

The colors that each distance value is mapped to is determined by the color table, which you can adjust in the Models module, under the ‘Scalers’ menu.

1 Like