mrc file- reading error

Hi all. I am trying to load 4 different volume files of some micro CT scans I did, but every time I try to open them in 3D slicer I get an error message that says the following:

Error occurred while loading the selected files.
Click ‘Show details’ button and check the application log for more information
Error: Loading /Users/deniseyamhureramirez/Desktop/I2_Test_Tomo_AreaD_Recon.transformed.mrc - load failed.

I have done this before with the same micro CT scanning and the files always work, but this last ones are not :(. The files were downloaded in the same way as the others from the box, and are saved as .transformed.mrc . They open fine in DragonFly, but not in Slicer, and I have tried in two different computers and the same error happens.
Does anyone know what the problem may be?

Please try to read the image using ITK-Python or SimpleITK. If loading fails then report the error to ITK developers on the ITK forum (Slicer uses ITK for reading mrc files).

If ITK can read the file then please upload an example file somewhere (dropbox, onedrive, …) and post the link here so that we can have a look.