mrmlScene is not available anymore in slicer module

Hi,

I updated my Slicer installation to 5.0.3 and my scripts stopped working because the attribute mrmlScene is not available in the slice module. I tried to reinstall slicer 5.3.0, install the pre-release 5.10 version, with no luck. This is a minimal code as an example that I tried in a Jupyter session (jupyter server initiated in slicer)

import slicer, vtk
#clear scene
slicer.mrmlScene.Clear(False)

AttributeError: module ‘slicer’ has no attribute ‘mrmlScene’

So what am I missing? Was there a change in the organization of the slicer module? I couldn’t find updated examples that could suggest a change in the module

EDIT: btw, trying to import JupyterNotebooksLib as slicernb crashes the jupyter kernel. So not sure truly how things got broken. Even reinstalling slicer is not fixing the issue.

Answering to myself… it seemed I had some weird settings in my $HOME/.jupyter directory , after deleting all there and being sure the right kernel was selected all started to work again .New versions of jupyter lab show the choice of kernels from several python installations, even if initiated from isolated python environments. This choice of python kernels can cause more problems like these.