My clipping plane moves when shift is pressed

For my module i am moving my mouse on the surface of a 3D model while holding shift (to get the surface coordinates)

But when I define a clipping plane on my model the clipping plane is moved/updated then doing this.

I expected to have the clipping plane stay at the location I have positioned it to.
Can I disable this behaviour?

The default behavior is that the cursor moves slices. You can disable it using the cursor button on the toolbar by choosing the No jump slices option: