New Module doesn't appear in Module Navigation Interface

I write a loadable module by ExtentenWizard, and then build it using cmake and visualstudio2013.
After that,I add additional path to 3Dslcier.(Application Setting Dialog -> Module -> Add additional module path), Restart Slcier!
But my custom module doesn’t appear in Module Navigation Interface.
My custom module path is D:\Slicer4D\Slicer-build\lib\Slicer-4.7\qt-loadable-modules, I am sure it’s OK.
I’ll appreciate it If someone can help me with the puzzle.
Ziheng Shen.

I have solved the problem.

What was the problem?

I should add the filepath of ‘lib’, not ‘Debug’.

I guess you mean you instead of this path:


you had to use this:

1 Like

The solution is to fix

Now that CTKAppLauncherLib is a dependency of Slicer, it should be fairly straightforward. The, updating the additional module path and restarting Slicer should allow to have all required path added the settings.