OpenCAD segmentation issue

Hello all,

I am having issue with OpenCad extension and occured during the the final steps of “Tumor Segmentation from DCE-MRI" tutorial

After designating the sample volumes (Pre, 1st-4th timepoints after DCE), I clicked Apply SegmentCAD and this log message came up:

Traceback (most recent call last):
File “C:/Users/uqmlim3/AppData/Roaming/NA-MIC/Extensions-28257/OpenCAD/lib/Slicer-4.10/qt-scripted-modules/”, line 619, in onSegmentCADButtonClicked
File “C:\Users\uqmlim3\AppData\Roaming\NA-MIC\Extensions-28257\OpenCAD\lib\Slicer-4.10\qt-scripted-modules\SegmentCADLogic\”, line 112, in renderLabelMap
AttributeError: ‘vtkCommonDataModelPython.vtkImageData’ object has no attribute ‘SetScalarTypeToShort’

I tried to follow the remedy in a similar post, but being very new I am not sure how to go about replacing the ‘’ with the fixed version. I tried searching the file ‘SegmentCADlogic’ in Slicer 4.10.2 Folder but nothing comes up. I can see other .py files but no SegmentCADlogic, as such am at the limit of my capabilities. Can anyone enlighten on how do i go about getting this fix please?

Slicer version: 4.10.1
Extension i’m facing issues: OpenCAD (Published on Wed Jun 02 2021) Documentation/4.3/Extensions/OpenCAD - Slicer Wiki
System: Windows PC

This is a pretty old extension written for Slicer 4.3 and I don’t know if it ever worked with 4.10.2. You might get what you need by using SlicerRadiomics in 4.11.