Plot data with Markers and without Line


It seems I can’t show markers.
I loaded the sample data:

# Get a volume from SampleData and compute its histogram
import SampleData
import numpy as np
volumeNode = SampleData.SampleDataLogic().downloadMRHead()
histogram = np.histogram(arrayFromVolume(volumeNode), bins=50)

chartNode = slicer.util.plot(histogram, xColumnIndex = 1)
chartNode.SetYAxisRange(0, 4e5)

But can’t remember how to hide line and show markers?

Slicer: 5.0.2 r30822 / a4420c3
Windows 11

It seems only cross and square marker styles works even they both represented as circles.
plus, circle, diamond doesn’t work at all.

I have attempted to replicate the issue using Slicer 5.0.2 like you and also latest Slicer stable 5.2.2, but I wasn’t able to replicate. Maybe a graphical issue of some sort. Can you replicate on another machine? What type of graphics might you be using (integrated, discrete GPU)? Anything else potentially unique about your setup?

1 Like

In the Series tab you need to change Data series from PlotSeries to Y first.

1 Like

We have that issue for a long-while, in GPA plots as well (only square is available). There is also this thread from the old, which doesn’t work for me… Setting of MarkerStyle does NOT work! - #8 by aiden.zhu

1 Like

@jamesobutler hi,

I tried on Ubuntu PC and there was no such error, i.e. everything works as expected.

On Windows 11 laptop I tried both integrated AMD Radeon(TM) Graphics and discrete NVIDIA GeForce RTX 3050 Laptop GPU but one of them worked. Still able to set only cross and square and they are shown as circle.

@muratmaga thank you for the post.
The proposition from the post works.
If I set $Env:SLICER_OPENGL_PROFILE = "core" then it works fine.