Possible malfunction with Slicer kernel for Jupyter notebook?


I’m trying to import the sitkUtils package in Jupyter notebook, I’m using the 3dSlicer kernel, which has worked perfectly for me before:

import sitkUtils as su

In a following cell I check if su is imported, which gives a correct output:

>> <module 'sitkUtils' from 'C:\\Users\\user\\AppData\\Local\\NA-MIC\\Slicer 4.11.20210226\\bin\\Python\\sitkUtils.py'>

A few cells later, I use a function in the su library and get the error

InputVolumeNode = su.PushVolumeToSlicer(input_volume)
>>NameError: name 'su' is not defined

However, rerunning this cell then says that other random packages and variables are not defined (which, again, were functioning well in other notebook cells):

>>NameError: name 'patient_list' is not defined
>>NameError: name 'sitk' is not defined

All of this is happening in 1 Jupyter notebook so I have no clue what could be wrong, but my guess is that the kernel is malfunctioning somehow?
Everything worked fine this morning.

I have tried restarting the kernel and restarting the terminal from which I am running the jupyter notebook. Running other pieces of code in different kernels seems to work fine as well.

Other than this, idk how to proceed, any advice?