Problem in loading the MRI files

Good morning,
I’m using the Slicer 4.11.0 version of the software to visualize and reconstruct Volume from MRI images of a breast tumor. Till yesterday I was able to load the DICOM file without any problem. Today i’m not able anymore to do it. I click on the DICOM module, I select the files I’m interested in and I click the load button. The software checks “DICOMScalarVolumePlugin”, “MultiVolumeImportPlugin” and “DICOMSlicerDataBundlePlugin”. It gives me some errors and it invites me to check the Python Console. It says this:

Geometric issues were found with 1 of the series. Please use caution.

Traceback (most recent call last):

File "C:\Program Files\Slicer 4.11.0-2019-03-24\lib\Slicer-4.11\qt-scripted-modules\DICOMLib\", line 732, in getLoadablesFromFileLists

loadablesByPlugin[plugin] = plugin.examine(fileLists)

File "C:/Program Files/Slicer 4.11.0-2019-03-24/bin/../lib/Slicer-4.11/qt-scripted-modules/", line 106, in examine

loadables += self.examineFiles(files)

File "C:/Program Files/Slicer 4.11.0-2019-03-24/bin/../lib/Slicer-4.11/qt-scripted-modules/", line 493, in examineFiles

mvNodes = self.initMultiVolumes(subseriesLists[key])

File "C:/Program Files/Slicer 4.11.0-2019-03-24/bin/../lib/Slicer-4.11/qt-scripted-modules/", line 885, in initMultiVolumes

mvNode.SetAttribute('MultiVolume.FrameFileList', frameFileListStr)

TypeError: SetAttribute argument 2: (unicode conversion error)

Warning: Plugin failed: MultiVolumeImporterPlugin

See python console for error message.

DICOM Plugin failed: SetAttribute argument 2: (unicode conversion error)

Warning in DICOM plugin Scalar Volume when examining loadable 601: dyn_eTHRIVE: Images are not equally spaced (a difference of 1 vs 0 in spacings was detected). If loaded image appears distorted, enable 'Acquisition geometry regularization' in Application settings / DICOM / DICOMScalarVolumePlugin. Please use caution.

DICOM plugin failed to load '601: dyn_eTHRIVE' as a 'Scalar Volume'.

Traceback (most recent call last):

File "C:\Program Files\Slicer 4.11.0-2019-03-24\lib\Slicer-4.11\qt-scripted-modules\DICOMLib\", line 862, in proceedWithReferencedLoadablesSelection

loadSuccess = plugin.load(loadable)

File "C:/Program Files/Slicer 4.11.0-2019-03-24/bin/../lib/Slicer-4.11/qt-scripted-modules/", line 422, in load

volumeNode = self.loadFilesWithSeriesReader("GDCM", loadable.files,

File "C:/Program Files/Slicer 4.11.0-2019-03-24/bin/../lib/Slicer-4.11/qt-scripted-modules/", line 299, in loadFilesWithSeriesReader


TypeError: SetArchetype argument 1: (unicode conversion error)

Could not load: 601: dyn_eTHRIVE as a Scalar Volume

What could I do? I tried to install older version too, but the problem is still there.

Looks like an issue with the characters used in the file path. Can you try again with only ascii characters?

Actually, yesterday I changed the name of the folder in which the DICOM images are saved. I tried to rename the folder with the previous name and I tried again to import and load the DICOM images. The problem still occurs.

In the error the program says this:
“Images are not equally spaced (a difference of 1 vs 0 in spacings was detected)”

But i didn’t touch in any way the images. I don’t understand why the software doesn’t load the images anymore.

Probably you can select a new dicom database location and re-import using the ascii directory paths.

I’m using anonymizated DICOM with the extension “.dcm” coming from an application crated with MATLAB. I tried so to use the original not anonymized file and with no extension. I tried to change location, too. It still doesn’t work.

There is a good chance that the anonymization process ruined the image by removing mandatory DICOM fields. You may be able to fix the data set by using Slicer’s “DICOM Patcher” module. If that does not help then you probably need to fix the anonymizer.

1 Like