Problem running slicer in Batch mode

I am trying to batch a number of operations in Slicer 3D to test my hypothesis however I ran into this strange problem of even making through example. Is there any pre-requisite in order to make this example script work?

What did you do exactly (what script you tried to run, what version of Slicer, what operating system, …)?
What did you expect to happen?
What happened instead? What was printed on the console? What was logged in the Slicer application log?

1 Like

I think that the new version of Slicer does not produce any output in the command line. For example, try running (I am using Windows) Slicer.exe --help. You won’t get any output…

On Windows, we decided to disable the console, because showing a console window is not common for Windows applications. Instead you can find all messages in the application log (menu: Help / Report a bug; or menu: View / Error log).

But I think when it is run from the command line, there should be some output, or at least the --help flag should output some useful flags to use Slicer.exe from the command line

I agree. This is a known issue (, but there have been always more important developments or fixes to do. If you add a comment to this issue explaining why it is important for you then it will more likely to get on the radar of a developer.