Problem when cropping! >> Transparent slices

So i have loaded a bunch of .pngs as a sequence into slicer…

When I dragged the first png onto the slicer window>> it offered me a pop up window where I chose>> show options>>> then unchecked the little box that says single file>> Then I chose fullrainbow next to it (maybe I should choose only rainbow and not the fullrainbow?!).

Either way once I click okay, the pngs load as a sequence and I can see them. I transform them a little bit, I flip the vertical axis (it is sadly upside down) and then I proceed to crop it.

The problem? When I crop a part of the volume>> the pngs seem to overaly each other and become transparent to a certain degree. So one always sees 2 pngs both somewhat transparent.

The hell?!
I use crop volume to crop it.

Then I close everything open the slicer again and load the sequence and this time before cropping it, I move the bar in the red perspective (coronary) all the way to the lowest slice and then move the bar a little bit right and then>>> they suddenly appear transparent again!! :S CATASTORPHY!

WHy would they not look transparent but then when I pull the bar and go to the lowest slice and then move back they become >> transparent. What the hell?

Then I tried to not do that and just don’t scroll to the lowest slice, instead I make sure that they are not transparent and then>> crop the volume.

Problem>>> on the cropped volume they still look transparent.

No matter what I do with the cropped volume, they remain cropped. I tried translation, move it it half a slice up, half a slice down, I tried scrolling it back to the beginning and scrolling it to the end. Nothing works… they remain cropped and transparent. What the hell?!


I must submit my project soon so this is very very scary now I might nor be able to solve it.

Could you add a few screenshots so that we can better understand what’s happening?

Can you give a bit higher-level view of what you are trying to achieve?

good idea! God bless you Andras, I’ve seen you help so many people on this forum

Here I have took a screenshot… If I delete number 5 up there it clears up and I see only one image.

What you see is the effect of interpolation between adjacent slices (when you move the slice slider to a position between two slices then there is a gradual fading between them). You can disable interpolation by unchecking “Interpolate” in Volumes module.

Indeed, unchecking interpolation makes images non-transparent and everything is beautiful.

However>>> cropping the volume still produced transparent volumes and no matter what i do with the cropped volume, I get them transparent (they remain transparent for the cropped volume, even after I turn off the interpolation.


btw thank you so much for replying, I am puzzled how much you are helpful and help people out! Amazing

Ohhh I just realized in cropping menu it says “interpolated cropping”… that one unchecked, crops the image perfectly without fusing them or making them transparent…

I wonder what is this feature interpolation is used at all

Normally, slices are spatially related, so when you are in between two slices then you want to see the a weighted average of the two closest slices. Most probably your image is not a real 3D volume (2D slices are misaligned, there are burnt-in 2D annotations, etc.) and that’s why interpolation is not desirable for visualization.

Thank you so much Lasso <3 You are life savior!

I will ask one more question in the forum I hope I am not annoying with the questions. It is not related to this issue so I will post it as a new thread.

Thank you soo so much!
Learning about slicer over and over and I’ve seen your answers in so many questions and wonderful explanations Lasso!

1 Like